Dieses Forum verwendet Cookies
Dieses Forum verwendet Cookies um deine Login Daten zu speichern (sofern Du registriert und angemeldet bist) bzw. deinen letzten Aufenthaltsort (wenn nicht registriert und angemeldet). Cookies sind kleine Textdateien, die auf deinen Rechner gespeichert werden. Die von diesen Forum gespeicherten Cookies werden ausschließlich für Zwecke dieses Forums verwendet und nicht von Dritten ausgelesen. Sie stellen kein Sicherheitsrisiko für deinen Rechner dar. Cookies werden in diesem Forum auch verwendet, um die Anzeige bereits gelesener und noch ungelesener Themen zu unterscheiden. Bitte bestätige, ob Du Cookies zulassen möchtest oder nicht.


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Temperatursensor defekt -> Varianten um trotzdem zu fahren?
#11
(14.11.2021, 13:52)jitensha schrieb: Hallo zusammen,

ich habe es nun endlich geschafft und der Temparatursensor meldet wieder normale Werte und das Bike entzückt wie ein junges Reh.
+ Etwas für die Nachhaltigkeit getan  (keinen funktionierenden Motor auf den Müll geworfen, alle Teile konnten wiederverwendet werden)
+ Etwas für mein Portemonnaie getan (ca. 1500 CHF gespart)
+ Einiges gelernt

Hat einiges an Geduld gekostet, gab auch ein paar Umwege, aber es war es für mich definitiv Wert.

Die Lösung ist sehr einfach wenn man sie weiss, kostet ca. 2 CHF an Material und 1h Arbeit  :
- Der Temperatursensor meldet falschen Wert
- Kabel und Ader identifizieren welchen den Temperatur Wert liefert
- Widerstand einbauen der die Temperatur wieder in den Korrekten Bereich führt.
- Gut isolieren + los cruisen

Weitere Details gebe ich gerne per PN.

Gute Lösung! Es gibt allerdings zwei Einschränkungen:

- Funktioniert nur, wenn der PT100 unterbrochen oder zumindest einen sehr hohen Ohmwert hat 
- Der Überhitzungsschutz des Motors wird dabei natürlich umgangen, bez. verhindert

Generell:
PT100 haben einen pos. Temperaturkoeffizienten. Bei 0 Grad haben sie i.d.R. 100 Ohm, jedes Grad mehr steigert den Ohmwert. Schaltet man einen 110 Ohm Widerstand in die Zuleitung zum Motor liegt dieser parallel zum eingebauten PT100. Ist dieser unterbrochen oder sehr hochohmig übernimmt dieser Widerstand diese Funktion und simuliert dem OMNI eine Motortemperatur von ca. 26 Grad.

   
Zitieren
#12
Mensch, was ihr alles für Sachen wisst. Wow. :-)
Zitieren
#13
(14.11.2021, 22:10)bluecat schrieb: War der PT100 nun ohne Widerstand oder mit unendlich Ohm?

(18.11.2021, 16:12)Hannes Buskovic schrieb: Mensch, was ihr alles für Sachen wisst. Wow. :-)

und mit den Antworten oben wird auch klar, was meine Frage soll...
Zitieren
#14
Photo 
Anbei noch die weiteren Details falls das auch jemanden auftritt. Eigentlich eine kurze Sache wenn man weiss wie - ich habe jedoch viele Stunden investiert um es herauszufinden.

Noch ein paar Erklärungen. Vor dem Umbau hat das Fahrrad bei mir ca. 145-152C gemeldet auch wenn es tagelang gestanden hast und dementsprechend hat die Software blockiert.

Auf dem ersten Bild sieht man den Stecker wo ich eingreifen konnte. Der Anschluss und das Kabel ist dort wo der Temperatursensor Wert überträgt wird. Ich habe dann um es zu testen ein Potentiometer (regelbarer Widerstand) angeschlossen. So konnte ich testen welche Widerstand welchen Wert ergbit.  Mit 50k Ohm Widerstand zeigte es bei -9C an und bei 10k Ohm 21C und bei sehr wenig Widerstand etwa 100C.  Ich habe mich danach entschlossen einen fixen 10k Ohm Widerstand einzubauen. Nun zeigt der Sensor Werte um 21C und schwankt ein paar Grad.

Natürlich habe ich nun keinen korrekten Wert - aber Differenzen sehe ich noch. Ich glaube kaum dass ich den Motor wirklich überhitze mit meiner Fahrweise und dass ihn so noch ein paar Jahre fahren und etwas für die Nachhaltigkeit tun kann. 

Neben Controller das Kabel ausstecken
   

Dieser Anschliuss liefert Temperatur
   

Diese Ader durchtrennt
   

Mit einem solchen Potentiometer den Widerstand gemessen
   

Erste Einbauvariante
   

Ich habe die Widerstände und Quetschverbinder von Conrad bestellt. Quetschverbinder ist dieser:
2x Klauke 769 Parallelverbinder 0.10 mm² 0.40 mm² Vollisoliert Gelb 1 St. - Conrad Electronic Schweiz
1x TRU COMPONENTS Metallschicht-Widerstand 10 kΩ axial bedrahtet 0207 0.6 W 1 % 1 St. - Conrad Electronic Schweiz

Wenn man sonst die Werkzeuge und Isolierband hat, wären das also 0.81 Franken Teilekosten vs. 1500 CHF Motorwechsel.
Zitieren
#15
(21.11.2021, 21:09)jitensha schrieb: Vor dem Umbau hat das Fahrrad bei mir ca. 145-152C gemeldet
...
Mit 50k Ohm Widerstand zeigte es bei -9C an und bei 10k Ohm 21C und bei sehr wenig Widerstand etwa 100C.  Ich habe mich danach entschlossen einen fixen 10k Ohm Widerstand einzubauen. Nun zeigt der Sensor Werte um 21C und schwankt ein paar Grad.
...
Wenn man sonst die Werkzeuge und Isolierband hat, wären das also 0.81 Franken Teilekosten vs. 1500 CHF Motorwechsel.

Die angezeigte Temperatur nimmt mit abnehmendem Widerstand zu -

Warum ist das so?

Wie gefällt Dir meine Rechung: Ich lade im Nidertarif für 8.45 Rp. / kWh und komme mit dem 983Wh Akku 70km weit. Das sind 0.00119 Franken pro Kilometer. 
Zitieren


Gehe zu: